Chosen

Module Drupal Illustration Voir sur Drupal.org
Nb téléchargements : 36162

Components

  • Code
  • Documentation
  • Miscellaneous
  • User interface

Images


Licence

http://www.gnu.org/licenses/old-licenses/gpl-2.0.html

permet d'utiliser la librairie jquery chosen pour rendre les select et multi select plus user friendly

Release

Status : Published
Projects : Modules
Maintenance status : Actively maintained
Development status : Under active development
Supported Branches : 3.0., 4.0.
shield Stable releases for this project are covered by the security advisory policy.



Description

Chosen uses the Chosen jQuery plugin to make your <select> elements more user-friendly.

Usage

By default the module will automatically apply itself to any select elements that have more than 20 options, which is a reasonable default for which having Chosen will be useful. To change or disable this automatic enhancement, you can change the selectors (or remove all selectors) from the Apply Chosen to the following elements field on the Chosen administration page.

FAPI #chosen property
For developers, you can force the Chosen plugin to be applied or never applied to your select FAPI element by adding $element['#chosen'] = TRUE; or $element['#chosen'] = FALSE; respectively.

Field UI
You can force enable/disable Chosen for certain field widgets: Select list (for both list and date fields), and Select (or other) list. If you have a field using one of these widgets, in the field settings, you will find a Apply Chosen to the select fields in this widget? option with three values: Apply, Do not apply, or No preference (which will fall back to using the automatic application).

Installation via Composer for Drupal 9-10-11

If you are using Composer to manage your site's dependencies, then follow the instructions depending on your module version:
For version 4.x:
The README contains all the information for the setup.
For version 3.x:
issue #3102250 comment #47.

Update with Composer for Drupal 9-10-11

composer require drupal/chosen:[version] -W

for example:
composer require drupal/chosen:4.0.1 -W

Installation via Drush

A Drush command is provided in the latest versions for easy installation of the Chosen plugin.

drush chosenplugin

The command will download the plugin and unpack it in the right folder.
It is possible to add another path as an option to the command, but not
recommended unless you know what you are doing.

Dependencies

The Drupal 9-10-11 version has no dependencies.

The 7.x-2.0-alpha2 and 7.x-2.0-alpha4 releases added a dependency on the jQuery Update module. As of 7.x-2.0-beta1 this dependency has been removed.

Maintainers

Dave Reid
Hydra
Bálint Nagy

Related Modules

Chosen AJAX by Cristhian



Toutes les informations proviennent du site drupal.org