Migrate Tools

Module Drupal Illustration Voir sur Drupal.org
Nb téléchargements : 54677

Components

  • Drush commands
  • User interface
  • Code
  • Documentation
  • Miscellaneous
  • Web UI

Documentation

Licence

http://www.gnu.org/licenses/old-licenses/gpl-2.0.html

permet d'avoir les commandes drush pour lancer les migrations, voir les états etc

Release

Status : Published
Projects : Modules
Maintenance status : Actively maintained
Development status : Under active development
Supported Branches : 6.0., 8.x-5.
shield Stable releases for this project are covered by the security advisory policy.






Description

The Migrate Tools module provides tools for running and managing Drupal migrations.

Drush commands supported include:

  • migrate:status - Lists migrations and their status.
  • migrate:import - Performs import operations.
  • migrate:rollback - Performs rollback operations.
  • migrate:stop - Cleanly stops a running operation.
  • migrate:reset-status - Sets a migration status to Idle if it's gotten stuck.
  • migrate:messages - Lists any messages associated with a migration import.
  • migrate:fields-source - List the fields available for mapping in a source
  • migrate:tree - Shows a tree of migration dependencies

A Web UI provides a front-end equivalent to many of the drush commands.

Versions

Note:
Since Drush 10.4 many of the drush commands are also available in Drush core. The code-base that made its way into Drush 10.4 was from an earlier and simpler fork of this module's code. For example, Drush does not support migrate plus config entities or provide a progress bar. Over time, the Drush team continues to add features and some of this might become incorporated upstream. The support team for Drush is unique from migrate tools. Any features or support requests for Drush core should be handled in its Github issue queue.

  1. 6.0.x - Compatible with Drupal 9+ and Drush 11+ and PHP 7.4+. This is where primary development will be focused.
  2. 8.x-5.x - Compatible with Drupal 8.8 || 9.0+ and Drush 9/10.
  3. 8.x-4.0-beta2+ - Compatible with Drupal 8.3.x and above and Drush 9. (Drush 8 support in 4.x is best effort at this point)
  4. 8.x-3.0-rc1 - Compatible with Drupal 8.2.x only, no longer supported.
  5. 8.x-2.0 - Compatible with Drupal 8.1.x only, no longer supported.
  6. 8.x-1.0 - Compatible with Drupal 8.0.x only, no longer supported.


Toutes les informations proviennent du site drupal.org